Kbase P104344: New Defined WebSpeed / AppServer broker fails to start with error (8108) and (8100) - Not using Prog
Autor |
  Progress Software Corporation - Progress |
Acesso |
  Público |
Publicação |
  16/10/2008 |
|
Status: Unverified
FACT(s) (Environment):
WebSpeed
SYMPTOM(s):
New Defined WebSpeed broker fails to start with error (8108) and (8100) - Not using Progress Explorer.
Started server: <serverStartupCmdLine> (8108)
Timeout while listening for server : java.io.InterruptedIOException: Accept timed out
ERROR: cannot start server. (8100)
Exception unbinding broker (not bound) : <brokername> (8525)
Started server: jvmStart _progres -ubpid xxxx -web -wtbhostname xxx.xxx.xxx.xxx. -wtbport xxxx -wtaminport xxxx -wtamaxport xxxx -wtbname WS-Broker-name -wtainstance 2 -ubpropfile ubroker.properties -logname WS-Broker-name -p web/objects/web-disp.p -weblogerror -pf ../cf.pf uuid=zzzzzz (8108)
CAUSE:
These errors are caused by a missing UUID for the Broker. These errors are very common to see for new created WebSpeed or AppServer brokers when the broker is created manually by editing the ubroker.properties, or it is copied from a previous Progress installation.
FIX:
To solve this make sure the necessary Unified Unique broker ID - UUID is placed in the Broker definition in the ubroker.properties.
To create the UUID use there are two options:
- use the command line tool: genuuid
or
- create the broker with the Progress Explore Tool (this generates the broker's UUID automatically).
Note: Progress Explorer is free for downloading on the Progress Download Center web site.