Kbase P104162: Remote 4GL client hangs with error 1280
Autor |
  Progress Software Corporation - Progress |
Acesso |
  Público |
Publicação |
  3/11/2010 |
|
Status: Verified
SYMPTOM(s):
Remote 4GL client hangs
Error 1280 in database log file
Connection timed out on socket=<n> for usernum <n>, attempt disconnect. (1280)
Connecting over a WAN
FACT(s) (Environment):
Progress 9.1D
IBM AIX POWER 5.2
CAUSE:
The exact cause is unknown at the time of this writing
FIX:
To work around the problem use the database startup parameter -PendConnTime.
To enable the -PendConnTime parameter add the following to your database startup:
Syntax: -PendConnTime (seconds) The time in seconds is the time allowed to the client to connect to a database server process. When the -PendConnTime is enabled, a counter is begun, when the counter elapses the auto server understands to modify its counts of pending client connections realizing that the client has not completed a successful connection. The broker is also updated to adjust its count of connected clients.