Kbase P104159: adminserver fails to start, and no admserv.log created
Autor |
  Progress Software Corporation - Progress |
Acesso |
  Público |
Publicação |
  15/03/2006 |
|
Status: Unverified
FACT(s) (Environment):
HP-UX 11i 64-bit
Progress 9.1D 64-bit
SYMPTOM(s):
adminserver fails to start
No admserv.log created
No ads0.exp created
Error messages appear only on screen
Exception in thread "main" java.lang.NullPointerException
at com.progress.common.util.acctAuthenticate.add37(acctAuthenticate.java:406)
at com.progress.common.util.acctAuthenticate.add37(acctAuthenticate.java:442)
at com.progress.common.util.acctAuthenticate.getValue(acctAuthenticate.java:532)
at com.progress.common.util.acctAuthenticate.generatePassword(acctAuthenticate.java:540)
at com.progress.common.util.acctAuthenticate.clientGeneratePassword(acctAuthenticate.java:796)
at com.progress.common.util.acctAuthenticate.generatePassword(acctAuthenticate.java:208)
at com.progress.chimera.adminserver.AdminServerType.main(AdminServerType.java:488)
CAUSE:
Bad network resolution of the hostname due to server machine having a fixed IP address and not using DNS.
FIX:
Ensure to use DNS.
If using DNS isn't possible, a possible workaround is to specify in the hosts file the hostname in place of "localhost".