Kbase P102806: Error 10830 accessing the target database
Autor |
  Progress Software Corporation - Progress |
Acesso |
  Público |
Publicação |
  11/5/2007 |
|
Status: Verified
FACT(s) (Environment):
Fathom Replication
All Supported Operating Systems
SYMPTOM(s):
Cannot connect to the Target Replication database
Connecting to the Target database returns error 10830
You are not licensed to access the database. (10830)
Fathom Replication Plus license installed
A network fault broke the connection between the Replication Server and the Replication Agent
defer-agent-startup is being used in the source.repl.properties
BROKER 0: Database connections are not allowed at this time. (10836)
CAUSE:
The Network failure interupted the connection between the Replication Server (RPLS) and the Replication Agent (RPLA), so the source and target databases were out of sync for a while. Once the Network fault had been addressed, the transition-timeout had already expired, and since manual transition is set up, the Replication Agent stops (Target database still running) and then the the Replication Server stops (not being able to communicate with the RPLA and Source database remains running).
The reason therefore why clients can't connect to a target database, is that replication is not in sync, eg not running, hence the access to target database is disabled until such time as the connection is able to be re-established and is established.
CAUSE:
Bug# OE00114776
FIX:
Upgrade to Fathom Replication 9.1E02 and OpenEdge 10.0B02 (or later) where this limitation on logins when the connection is down has been removed.
Alternatively:
Restart replication server and agent so that they can re-establish connection and synchronise the target database with the source database:
1.) The Replication Agent (RPLA) needs to be restarted by restarting the target database.
2.) the Replication Server (RPLS) can be restarted without having to shut down the source database through the use of the DSRUTIL utility:
$ DSRUTIL source -C restart server