Kbase P96584: Fathom Mgmt fails to stop or start after adding containers
Autor |
  Progress Software Corporation - Progress |
Acesso |
  Público |
Publicação |
  5/4/2009 |
|
Status: Verified
SYMPTOM(s):
Errors starting of stopping Fathom after Fathom containers have been added
Problems starting console after adding remote agents
Waiting for active work threads to complete. (11218)
Error when starting Fathom.
* Error starting Fathom probe: "NULL" (10148)
Fathom startup failed. (9661)
java.rmi.ConnectException: Connection refused to host: <IP-address>; nested exception is:
java.net.ConnectException: Connection refused...
Exception: java.lang.NullPointerException Message (throw): Error starting Fathom probe.
Starting or stopping Fathom after adding Containers
FACT(s) (Environment):
All Supported Operating Systems
OpenEdge Management
Fathom Management
CAUSE:
Bug# OE00110266
CAUSE:
File corruption in configuration directory
FIX:
Upgrade to Fathom Management 3.0A02 or later. There were a number of remote agent issues that were resolved in the 3.0A02 service pack and Progress development suspect that these bugs were the cause.
Workaround:
To start Fathom perform one of the following:
1. If a backup of the configuration files exist, restore backups of your configuration files.
2. If a backup of the configuration files does not exists, perform the following steps to restart Fathom:
1) Backup of the SonicMQ directory and all of it's sub directories.
2) Shutdown the AdminServer (proadsv -stop).
3) Disable remote monitoring (fmconfig -disable).
4) Restart the AdminServer (proadsv -start).
5) The AdminServer should start without error. If any errors make record of them.
6) Delete remote containers using the Fathom console.
7) Shutdown the AdminServer (proadsv -stop).
8) Re-enable remote monitoring with the update parameters (fmconfig -update).
9) Start AdminServer (proadsv -start).
10) AdminServer should start without error. If any errors make record of them.
11) Reconnect remote machines (fmconfig -update -host HostName).