Kbase P103861: Can not connect Progress Explorer to an AdminServer running on UNIX
Autor |
  Progress Software Corporation - Progress |
Acesso |
  Público |
Publicação |
  5/3/2005 |
|
Status: Unverified
FACT(s) (Environment):
HP-UX
Progress 9.1x
OpenEdge 10.x
SYMPTOM(s):
Can not connect Progress Explorer to an AdminServer running on UNIX
Unable to connect to Admin Server. Ensure Admin Server is running. (8336)
RegistryManager - could not get hostname, using "localhost"
[RegistryManager] Host: localhost (7868)
CAUSE:
The AdminServer was starting using "localhost" for the host name. The machine was having DNS problems.
FIX:
If the network administrator is not able to resolve the DNS issue a work around is to reconfigure nsswitch to search the host file before using DNS.
For example using the HP "sam" utility:
The output of sam -> Networking and Communications -> Name Service Switch
¦¦ hosts DNS NIS /etc/hosts
Reconfigure nsswitch to use the host file first.
The new output from sam -> Networking and Communications -> Name Service Switch
¦¦ hosts /etc/hosts DNS NIS