Consultor Eletrônico



Kbase P102647: Fathom AdminServer dies when starting dbagent for scripted databases
Autor   Progress Software Corporation - Progress
Acesso   Público
Publicação   03/11/2008
Status: Verified

SYMPTOM(s):

Fathom AdminServer dies when starting dbagent for scripted databases

As soon as the remote dbagents are started up, AdminServer/Fathom dies

Remote database stays running after the dbagent is started for it

Remote database log files shows error 8848

Connection to Admin Server lost. (8848)

Last entry in the admserv.log shows initialization of binding to the remote resource

Binding resource to surrogate. Container name: <container_name> Resource name: <remote database name>

A java thread core dump from the java.exe failing on the rocket engine is thrown hs_err_pid<number>.log

Java core file reads:

An unexpected exception has been detected in native code outside the VM.
Unexpected Signal : EXCEPTION_ACCESS_VIOLATION occurred at PC=0x1BEC8ED0
Function=pmRecvMsg+0x400
Library=<Progress $DLC>\bin\rocket.dll

Connection from Progress 9.1D09 dbagent to OpenEdge 10.0B01 AdminServer is supported

Connection from Progress 9.1E dbagent to OpenEdge 10.0B01 AdminServer is supported

No errors in ads0.exp file

FACT(s) (Environment):

Fathom Management 3.0A
All Supported Operating Systems
Cannot shut down NameServer
Cannot access Fathom Management Console

CAUSE:

Bug# 20050322-007

CAUSE:

This is caused by the fact that the VST and System table schema definitions are different between Progress 9 and OpenEdge 10. Remote version 9 database agents connecting to version 10 AdminServer causes the AdminServer to crash because we parse version 9 data using version 10 definitions. To correct this problem, the database agent was enhanced to report which version of the product it is running from. The AdminServer was also enhanced to parse the new agent data and use the appropriate VST/system schema based on the Progress version.

FIX:

Upgrade to OpenEdge 10.0B02, Progress 9.1D02 where these enhancements have been added.

To initially address the problem:
1.) The server will have to be rebooted ideally, to clear the zombie java.exe processes that are left behind. The NameServer cannot be killed off successfully otherwise.
2.) Remove the remote monitored databases for Progress 9 from Fathom Management until you are able to apply the related SP02 to your Progress installation.