Kbase P101026: Progress Explorer reporting Startup of database <dbname> failed - File not found (JUNMsg023)
Autor |
  Progress Software Corporation - Progress |
Acesso |
  Público |
Publicação |
  14/04/2005 |
|
Status: Unverified
FACT(s) (Environment):
UNIX
SYMPTOM(s):
Databases administrated through Progress Explorer report failure to start
Startup of database <dbname> failed - File not found (JUNMsg023)
AdminServer is not started with root account
Databases are started despite the error message
CHANGE:
Been making changes to items in the Progress Explorer screen, eg: minport maxport
CAUSE:
The "proadmin" (or non-root) user that has been setup to start the AdminService, does not have sufficient permissions to change the relevant.properties files
FIX:
Change the permissions in $DLC/properties/* to 666, so that the non-root user has sufficient privalleges.
Alternatively, change the ownership of these .properties files to that of the non-root user (eg: proadmin) and group to the same as the group on the Progress executables.
1. chown proadmin : progress *
chmod 664 *
2. Restart the AdminServer
3. and then continue to configure the whatever items in the Progress Explorer you were changing, so that the properties will get updated.