Consultor Eletrônico



Kbase P102303: Installing Progress Service Pack fails with category.dll error
Autor   Progress Software Corporation - Progress
Acesso   Público
Publicação   12/2/2008
Status: Verified

SYMPTOM(s):

Installing Progress Service Pack fails with category.dll error

Installing additional product to an existing installation

Installing OpenEdge Service Pack fails with category.dll error

Installation failed because there is a mapped section open : category.dll

The requested operation cannot be performed on a file with a user-mapped section open

FACT(s) (Environment):

Windows
Progress/OpenEdge Product Family

CAUSE:

Another service is using the category.dll file which is needed by Progress during the installation.

FIX:

There are two methods to resolve this:

A. Black Box reboot
1. Stop all Progress processes
2. Shut down Progress AdminService and set the service to 'Manual' startup
3. Reboot the machine
4. Make sure that there are no Progress related processes running
5. Make a backup of %DLC%\ specifically the %DLC%\properties directory
6. Re-install Progress and skip the option to "Backup current installation"


B. White Box find

1. Download filemon from http://www.microsoft.com/technet/sysinternals/default.mspx (Sysinternals is part of Microsoft)
2. Find out from all running processes, which one has is using the category.dll, for example WinMgmt or 'Windows Management Instrumentation' is known to be a likely suspect
3. Stop that service/process
4. Progress installation will now finish