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Kbase P102291: Getting error 8230 when connecting to the AppServer from .Net client with multiple NameSerVers insta
Autor   Progress Software Corporation - Progress
Acesso   Público
Publicação   30/10/2009
Status: Verified

SYMPTOM(s):

Getting error 8230 when connecting to the AppServer from .Net client

Connect Failure: NameServer Communications Failure - <Java Exception> (8230)

Connect Failure: NameServer Communications Failure - System.NetSockets.SocketException: An existing connection was forcibly closed by the remote host
at Progress.UdpClientSupport.Receive(UdpClientSupport tempClient, PacketSupport packet)
at Progress NameServer.Client.NameServerClient.receiveResponse(Int32 responseCount, String applicationService) (8230)

FACT(s) (Environment):

There are multiple NameServers from different Progress versions installed on the machine
Connection works fine when bypassing the NameServer by specifying the AppServer's port number instead
OpenEdge 10.x
Windows

CAUSE:

The AppServer is not properly registered to the NameServer.

FIX:

First, ensure that the NameServer that the .Net client is connecting to is the correct one. i.e. that the NameServer port number that the .Net client specifies is correct.

If it is correct and that is not the cause, there are 2 other options:

1- Connect to the AppServer without the NameServer.

For this, specify the AppServer's port number in the connection string and use the 'AppServerDC' keyword instead.
AppServerDC://<Host Name>:<AppServer Port Number>


OR


2- Start manually the NameServer from Proenv.

From Proenv, type a command similar to the following:
nsman -i <NameServer's name> -start