Kbase P101643: Some web browsers hang when trying to run WebSpeed programs.
Autor |
  Progress Software Corporation - Progress |
Acesso |
  Público |
Publicação |
  12/29/2005 |
|
Status: Unverified
SYMPTOM(s):
Some web browsers are hanging when trying to run WebSpeed programs.
WebSpeed program won't run.
WebSpeed license has not been exceeded.
Querying the WebSpeed broker shows that all existing agents are BUSY.
The number of agents started is less than the WebSpeed license count.
CAUSE:
The WebSpeed broker has not been correctly configured to start the appropriate number of agents. There are parameters that denote how many agents can start per broker.
Therefore, there aren't enough WebSpeed agents to service the number of users so users hang waiting for an available agent.
FIX:
To correct this, modify the WebSpeed broker settings by either editing the $DLC/bin/ubroker.properties file manually or by using the Progress Explorer tool:
Each broker's parameters can only be set as high as the WebSpeed licensed user count. If they are set higher then the broker will still only start as many as the license count. Also note that the WebSpeed license is for all agents started regardless of how many brokers you are using. For example if you have a 25 agent WebSpeed license, although it is possible to start two or more brokers each with 25 agents it would breach the WebSpeed license agreement.
ubroker.properties:
1. Open the ubroker.properties file in an editor. The ubroker.properties file is found in the 'properties' subdirectory of the Progress installation directory.
2. Find the block that starts with "[UBroker.WS.<brokerName>]", where <brokerName> is the name of your broker. The following parameter lines need to be adjusted (if they already exist), or they can be added as needed:
initialSrvrInstance=5
minSrvrInstance=1
maxSrvrInstance=10
3. After adjusting the values and saving the file a stop and restart of the AdminServer and WebSpeed broker(s) is required.
Progress Explorer:
1. Open Progress Explorer and connect to the appropriate AdminServer.
2. Expand each node until the relevant WebSpeed broker name is shown; i.e. <hostname>\WebSpeed\<BrokerName>
3. Right-mouse-click on the broker name and select "Properties".
4. Expand the "Agent" branch and select "Pool Range".
5. Adjust the parameters as required.
6. Restart the WebSpeed broker(s).