Kbase P101577: Starting SqlExplorer with a non administrator account is hanging.
Autor |
  Progress Software Corporation - Progress |
Acesso |
  Público |
Publicação |
  25/02/2005 |
|
Status: Unverified
FACT(s) (Environment):
Windows
SYMPTOM(s):
Starting SqlExplorer with a non administrator account is hanging.
SqlEplorer never errors out.
Task Manager shows wjview.exe eventually consumes 98-99% of the CPU.
The administrator's account had started a SqlExplorer session without a problem.
CAUSE:
The SqlExplorer Log files are owned by the Administrator account because they were the first to run SqlExplorer. Because some of the log files can not be opened by the non administrator account the startup process can not complete.
The SQLExplorer.exceptions log is updated with the exceptions errors at a very fast rate causing the file to grow rather large in a very short time.
The wjview.exe process must be manually killed to stop the exceptions log from growing and the free up the cpu.
Errors that are repeated in the exception log file are:
at com/progress/chimera/common/Tools.px
at com/progress/common/log/LogFile.open
at com/progress/common/log/LogFile.write
at com/progress/common/log/LogFile.write
at com/progress/common/log/LogSystem.writeIt
at com/progress/common/log/Subsystem.write
at com/progress/common/log/Subsystem.logErr
at com/progress/common/log/Subsystem.logErr
at com/progress/common/log/Excp.print
FIX:
Create the SqlExplorer log files from the non administrator account and then the files may be used by both of the accounts without a problem. To do this follow the steps below.
1. Open task manager and kill the wjview.exe process if it is still running.
2. Copy the SqlExplorer log files to a new directory if needed for historical purposes.
3. Delete the following SqlExplorer logs in the working directory.
sqlexp.log
SQLExplorer.history
SQLExplorer.properties
SQLExplorer.exceptions
4. Start a SqlExplorer session from the non administrator account.