Kbase P99230: No installation of Progress found when trying to install Service Pack
Autor |
  Progress Software Corporation - Progress |
Acesso |
  Público |
Publicação |
  12/23/2004 |
|
Status: Unverified
FACT(s) (Environment):
Windows
Progress 9.1D
SYMPTOM(s):
Installation of Service Pack fails with error
You must first install Progress v9.1D before installing this service pack. Click OK to exit.
Progress has been installed on the machine
Progress has been working properly on the machine
CAUSE:
Progress keys were missing or not present in the Registry
Missing:
HKEY_CURRENT_USER\Software\PSC\PROGRESS\9.1D\
Empty:
HKEY_LOCAL_MACHINE\Software\PSC\PROGRESS\9.1D\
FIX:
1) Reinstall Progress and then apply the Service Pack.
2) Run the INI2REG utility in $DLC\Bin to translate the Progress.ini file (or equivalent) into the Registry to restore these keys and/or their related entries. Note that:
- INI2REG will import the values as they are in the Progress.ini file
- INI2REG will only restore the keys from \Software\PSC\PROGRESS\9.1D\; if other Registry entries are missing then Progress should be reinstalled completely