Kbase P98775: AdminServer does not automatically start in Windows Services
Autor |
  Progress Software Corporation - Progress |
Acesso |
  Público |
Publicação |
  15/10/2008 |
|
Status: Verified
SYMPTOM(s):
AdminServer does not automatically start in Windows Services
Trying to start AdminService manually produces errors
Could not start AdminService for OpenEdge 10.0B service on local computer
Error 1053: The service did not respond to the start or control request in a timely fashion
AdminServer log error shows: java.lang.NoClassDefFoundError: com/sonicsw/mf/common/runtime/INotification (11491)
AdminServer set up to use non-default port settings
FACT(s) (Environment):
OpenEdge 10.0B
Windows XP
CHANGE:
Added an additional Progress product to the existing installation
CAUSE:
The install program runs tailoring DLLs whenever any installation is performed. This includes adding additional products to an existing installation.
The tailoring DLL for the AdminServer always writes new copies of the AdminServer keys to the registry, using the default settings (-port 20931 and -adminport 7835 in some Open Edge releases, see solution P104080). This is the intended behavior.
FIX:
To resolve the issue edit Windows registry to change the AdminServer default port settings to desired port settings.
Ports may need to be set for both the -port and -adminport values.