Consultor Eletrônico



Kbase P98768: DATADIRECT 4.10 32-BIT Progress SQL92 Driver is not available on NetSetUp client
Autor   Progress Software Corporation - Progress
Acesso   Público
Publicação   28/02/2008
Status: Verified

FACT(s) (Environment):

Windows NT 32 Intel/Windows 2000
Progress 9.1E
OpenEdge 10.0x
DataDirect 4.10 32-Bit Progress SQL92 9.1E
DataDirect 4.20 32-Bit OpenEdge SQL92 10.0B

SYMPTOM(s):

NetSetup installation will not add the SQL Client Access

Get ODBC driver installed with NetSetup.

Unable to setup ODBC connection to Progress under ODBC Data Source Administrator on the client

No errors reported during NetSetup

DATADIRECT 4.10 32-BIT Progress SQL92 v9.1E driver is not available on NetSetup client

Cannot see ODBC driver for Progress 9.1E client after installation

The PGPRO918.DLL is present under %DLC%/bin directory on the Server machine

DataDirect 4.20 32-BIT OpenEdge SQL v10.0x driver is not available on NetSetup client

Cannot see ODBC driver for Progress 10.0x client after installation

The PGPRO1019.DLL is present under %DLC%/bin directory on the Server machine

CAUSE:

Bug# OE00111987

CAUSE:

Bug# OE00116288

CAUSE:

NetSetup does not create the required registry key for DataDirect/Merant driver on the Client's machine.

FIX:

Option #1
Upgrade to 9.1E02 or later.
Upgrade to 10.0B03 or later.

After applying the service pack on the file server, redo the NetSetup on the clients machine to ensure registry keys are properly created.


Option #2
Manually add the registry keys which will make the driver accessible.

Progress 9.1E
1. Copy the lines below for Progress 9.1E, between <begin> and <end> into a file as xx.reg.

2. Alter the path for the Progress installation (eg: H:\\91E = <mapped drive>:\\<value of %DLC%>. The double \\ marks are correct for the "Driver" and "Setup" lines, do not change this for the import, only change the drive letter and directory names.

3. Exclude the <begin> and <end> lines if they were copied into the xx.ref file.

4. Import the xx.reg into the registry via regedit.

Sample .reg file for Progress 9.1E:

<begin>
Windows Registry Editor Version 5.00

[HKEY_LOCAL_MACHINE\SOFTWARE\ODBC\ODBCINST.INI\DATADIRECT 4.10 32-BIT Progress SQL92 v9.1E]
"APILevel"="1"
"ConnectFunctions"="YYN"
"CPTimeout"="60"
"Driver"="F:\\91E\\DLC\\bin\\PGPRO918.DLL"
"DriverODBCVer"="4.10"
"FileUsage"="0"
"Setup"="F:\\91E\\DLC\\bin\\PGPRO918S.DLL"
"SQLLevel"="0"
"UsageCount"="1"
[HKEY_LOCAL_MACHINE\SOFTWARE\ODBC\ODBCINST.INI\ODBC Drivers]
"DATADIRECT 4.10 32-BIT Progress SQL92 v9.1E"="Installed"
<end>


OpenEdge 10.0x
1. Copy the lines below, between <begin> and <end> into a file as xx.reg.

2. Edit the path to the Progress installation (eg: F:\\100B = <mapped drive>:\\<value of %DLC%>. The driver will then be accessible. The double \\ marks are correct for the "Driver" and "Setup" lines, do not change this for the import, only change the drive letter and directory names.

3. Edit the Driver Name to match the version of Progress 10.0x being run.

4. Exclude the <begin> and <end> lines if they were copied into the xx.ref file.

5. Import the xx.reg into the registry via regedit.

Sample .reg file for OpenEdge 10.0x:

<begin>
Windows Registry Editor Version 5.00

[HKEY_LOCAL_MACHINE\SOFTWARE\ODBC\ODBCINST.INI\DataDirect 4.20 32-BIT OpenEdge SQL v10.0B]
"APILevel"="1"
"ConnectFunctions"="YYN"
"CPTimeout"="60"
"Driver"="F:\\100B\DLC\\bin\\PGPRO1019.DLL"
"DriverODBCVer"="4.20"
"FileUsage"="0"
"Setup"="F:\\100B\\DLC\bin\\PGPRO1019S.DLL"
"SQLLevel"="0"
"UsageCount"="1"
[HKEY_LOCAL_MACHINE\SOFTWARE\ODBC\ODBCINST.INI\ODBC Drivers]
"DataDirect 4.20 32-BIT OpenEdge SQL v10.0B"="Installed"
<end>