Consultor Eletrônico



Kbase P98678: Can not run Progress Explorer and no error message is given.
Autor   Progress Software Corporation - Progress
Acesso   Público
Publicação   19/11/2008
Status: Verified

SYMPTOM(s):

Unable to run Progress Explorer selecting icon in the Progress Program Folder.

No errors returned.

Unable to run proexp.bat from a proenv session.

Running proexp.bat from the command line only returns Progress Version 9.X... information.

Running proserve from proenv window gives Java error.

Unable to set -c <classpath> option, error in argument:(@{JAVA\JRECP};@{JAVA\FATHOMCP})

Progress entries missing from registry.

FACT(s) (Environment):

Progress 9.x
Windows
OpenEdge 10.x

CAUSE:

A Windows update was done which corrupted the registry entries for Progress.

FIX:

The registry settings for Progress must be restored. There are two ways to accomplish this:
1. Restore HKEY_LOCAL_MACHINE\SOFTWARE\PSC from a backup.
2. The Progress uninstall must be run and Progress installed again to restore the registry.
If the uninstall does not work Progress will have to be removed manually to allow Progress to be installed and the registry updated.