Kbase P98500: Can't start Fathom after upgrading from Fathom Management 2.1A to Fathom Management 3.0A
Autor |
  Progress Software Corporation - Progress |
Acesso |
  Público |
Publicação |
  04/12/2008 |
|
Status: Verified
SYMPTOM(s):
Can't start Fathom after upgrading from Fathom Management 2.1A to Fathom Management 3.0A
Multiple java configuration errors in admserv.log file
WARN!! Configuration error on C:\FATHOM\WORK
java.util.zip.ZipException: The system cannot find the path specified
Errors in the ads0.exp
WARN!! Configuration error on jar:file:/C:/Program Files/Fathom/jars/fathomhelp.jar!/
java.util.zip.ZipException: The system cannot find the path specified
Message (throw): Error starting Fathom probe.
Message (excp): Web Server startup failurejava.util.zip.ZipException: The system cannot find the path specified
FACT(s) (Environment):
Fathom Management 3.0A
Progress 9.1D
CAUSE:
Bug# 20031008-036
CAUSE:
Bug# 20050203-020
CAUSE:
Fathom is being installed into a directory with spaces in the name, e.g. c:\program files\progress. The following Fathom 3.0A jar files are causing the problem:
xalan.jar
xercesImpl.jar
xml-apis.jar.
FIX:
Upgrade to 3.0A02.
To workaround the problem:
1) Get the 2.1A01 versions of xalan.jar, xercesImpl.jar, xml-apis.jar
2) Copy these files into the c:\program files\fathom\jars directory
3) Restart the AdminServer\fathom to complete the upgrade of Fathom
4) Stop the AdminServer and Fathom Trend Database
5) Run "fathom -dump c:\temp\fathom.xml" to dump the configuration
6) Probkup the fathom trend database
7) Backup the fathomRelam.properties file to preserve users and password.
8) Uninstall Fathom 3.0A
9) Reinstall Fathom 3.0A into a directory without spaces in the path (e.g. c:\progress\fathom).
10) Copy the fathom.xml and fathomRealm.properties into the config directory (e.g. c:\progress\fathom\config).
11) Restore the Fathom Trend Database into the db directory (e.g. c:\progress\fathom\db)
12) Reboot
13) Restart the AdminServer/Fathom.
14) After Fathom starts, connect to the Fathom Management Console and Change the location of the Fathom Trend Database in the Options/Trend Database menu option. It will still be pointing to the old directory (c:\program files\progress\db).
15) Restart the Fathom trend database.