Kbase P97995: ProxyGen fails to generate a proxy on a machine with different Progress versions installed
Autor |
  Progress Software Corporation - Progress |
Acesso |
  Público |
Publicação |
  15/06/2005 |
|
Status: Unverified
FACT(s) (Environment):
OpenEdge 10.x
SYMPTOM(s):
The ProxyGen fails when generating a Java proxy
Proxy Generation Process failed to run.
Try running <path>\runbproxygen.bat in a Command prompt.
It also fails when running runbproxygen.bat.
The ProxyGen fails to generate any Proxy (Java, .Net, Web Services)
The ProxyGen log file is not created
There are different versions of Progress installed on the machine
CAUSE:
The DLC variable defined as a Windows environment variable still refers to an old Progress version.
FIX:
To fix the problem, change the DLC environment variable in order to point to the proper OpenEdge version.
For example, the DLC variable is still referring to a Progress 9.1D installation on Windows XP.
To fix the problem, follow the steps below:
1- Go to Start -> Settings -> Control Panel -> System
2- Click on the tab "Advanced"
3- Click on the button "Environment Variables"
There are here 2 options:
4a) Adjust the DLC variable to the OpenEdge 10 installation
OR
4b) Delete the DLC variable from the Windows environment variables.