Consultor Eletrônico



Kbase P97832: Progress 9.x JDBC won't connect to an OpenEdge 10.x database.
Autor   Progress Software Corporation - Progress
Acesso   Público
Publicação   4/14/2010
Status: Verified

SYMPTOM(s):

Progress 9.x JDBC won't connect to an OpenEdge 10.x database.

Cannot connect from Progress version 9 to OpenEdge 10 via JDBC

FACT(s) (Environment):

All Supported Operating Systems
Progress 9.x
OpenEdge 10.x

CAUSE:

This is the expected behavior. A client using Progress 9.x JDBC can only connect to a database of equal major version. A 9.x JDBC client cannot connect to an OpenEdge database.

FIX:

Upgrade the 9.x JDBC client to OpenEdge 10.x

The Progress SQL Client Access product contains JDBC. Although this is a standalone product, it is also a subset of other Progress products too.