Kbase P97799: Error "Server did not respond" trying to connect to database using SQL Explorer
Autor |
  Progress Software Corporation - Progress |
Acesso |
  Público |
Publicação |
  11/18/2004 |
|
Status: Unverified
FACT(s) (Environment):
Progress 9.x
OpenEdge 10.x
SYMPTOM(s):
SQL Explorer fails to connect to the database
ODBC connections to the same database works fine
SQLState=HY000
ErrorCode=-30033
[JDBC Progress Driver]:Server did not respond
java.lang.UnsatisfiedLinkError: java/security/AccessController.doPrivileged Possible causes: If you are trying to use J/Direct (@dll.import), check your compiler version (for JVC, requires 4336 or greater.) If you are trying to use RNI, there are new requirements: see documentation.
Connection timed out on socket=<n> for usernum <n>, attempt disconnect. (1280)
Connection timed out on socket=32 for usernum 1, attempt disconnect. (1280)
CAUSE:
PROCLI92.DLL from another Progress version in the C:\WINDOWS\SYSTEM32 directory
FIX:
PROCLI92.DLL is located under %DLC%\bin but if the same file is in a search path that precedes %DLC%\bin SQL Explorer will use the first one it finds. To check for existence of PROCLI92.DLL from different Progress/OpenEdge versions that could be causing this problem follow the steps bellow:
1. Search the machine for any PROCLI92.DLL that could be located in a directory different from %DLC%\bin
2. Usually the directories C:\WINDOWS and C:\WINDOWS\SYSTEM32 precedes %DLC%\bin
3. If you find the file, rename it
4. Log back into SQL Explorer and try to connect to the database again
To avoid any DLL version conflict, keep PROCLI92.DLL under %DLC%\bin so each version of Progress/OpenEdge will be able to find this file on the correct location.