Consultor Eletrônico



Kbase P97780: Error "Unable to download application configuration file" when launching Webclient for the second ti
Autor   Progress Software Corporation - Progress
Acesso   Público
Publicação   06/01/2009
Status: Verified

SYMPTOM(s):

WebClient application runs successfully on the first attempt after installation

Receives an error when running the application on the second and subsequent attempts

Unable to download application configuration file <path to .prowcapc file>

Error occurs when running from WebClient application shortcut

.prowcapc file is found when running the path returned in the error message

Entries in the ProwcappLocator Registry key are correct

Path entries in the .prowcapp file are correct

Uninstalling and reinstalling the WebClient application does not fix the error

FileMon log file set to filter on prowcini.exe showed the following entries:

prowcini.exe:256 QUERY INFORMATION <path to .prowcapc file> SUCCESS
prowcini.exe:256 CREATE C:\DOCUME~1\<username>\LOCALS~1\Temp\<filename>.prowcapc ACCESS DENIED <domain>\<username>

.prowcapc file exists in user's Temp folder

.prowcapc file in user's Temp folder is set to Read-Only

Application runs if .prowcapc file in Temp folder is removed

Application is re-run then a Read-Only .prowcapc file is recreated in Temp folder and the error occurs again on subsequent attempts

FACT(s) (Environment):

Progress 9.1x
OpenEdge 10.x
Windows

CAUSE:

The .prowcapc file on the server is set to Read-Only. This file should be removed when the application is closed but this process fails due to the Read-Only setting. When the application is re-launched, it attempts to create a new version of the .prowcapc which fails.

FIX:

Ensure that the .prowcapc file on the server is not set to Read-Only