Kbase P97599: Unable to start a database using AdminServer
Autor |
  Progress Software Corporation - Progress |
Acesso |
  Público |
Publicação |
  23/10/2008 |
|
Status: Unverified
SYMPTOM(s):
Unable to start a database using AdminServer
Cannot start a database using Progress Explorer
dbman fails with ERROR: Database <db> failed to start (DBMan022)
[ConnectionManager] * Config db.defaultconfiguration - Message from db.defaultconfiguration.defaultservergroup (primary): [.db, errno = 2. (43)] (ADMMsg057)
[ConnectionManager] * Config db.defaultconfiguration - Error from db.defaultconfiguration.defaultservergroup (primary): BROKER : ** This process terminated with exit code 2. (8619)] (ADMMsg005)
The database files permissions are set correctly
The database files are present in the specified directory
Can start a database using proserve without any problems
FACT(s) (Environment):
Progress 9.1X
OpenEdge 10.X
Linux Intel
CAUSE:
Corrupted $DLC/properties/conmgr.properties file
FIX:
Stop the AdminServer, create an empty $DLC/properties/conmgr.properties file, start the AdminServer and re-add your databases using Progress Explorer.