Consultor Eletrônico



Kbase P97143: Unable to connect to AdminServer on UNIX - error 8336
Autor   Progress Software Corporation - Progress
Acesso   Público
Publicação   22/06/2009
Status: Verified

SYMPTOM(s):

Unable to connect to Admin server from Progress explorer

Unable to connect to Admin Server. Ensure Admin Server is running. (8336)

Progress explorer issues error 8336 when connecting to admin server

proadsv -q says AdminServer is alive

Admin server is running on UNIX

There is no firewall between AdminServer and machine with Progress Explorer

FACT(s) (Environment):

Progress 9.1X
OpenEdge 10.X
UNIX

CAUSE:

Network on the UNIX machine is set incorrectly

FIX:

In order to fix the problem:

1) issue "hostname" command
2) issue "ifconfig" command
3) open "/etc/hosts" file and make sure it looks following way

127.0.0.1 localhost
ip_address hostname (hostname.yourdomain.com)
.....
.....
other necessary entries

ip_address = ip address from "ifconfig" command which belongs to your primary adapter
hostname = output from "hostname" command

example:
127.0.0.1 localhost
192.168.1.5 linux linux.mydomain.net

4) restart the AdminServer
5) now the connection from Progress Explorer will work