Kbase P97056: AppServer will not start if configured to automatically connect to a database on mapped drive
Autor |
  Progress Software Corporation - Progress |
Acesso |
  Público |
Publicação |
  2/24/2009 |
|
Status: Verified
SYMPTOM(s):
AppServer will not start
FACT(s) (Environment):
Windows
No errors in AppServer broker or server log files
AppServer configured to connect to database on startup
Database is on remote drive which is mapped to a drive letter
Same database copied to local drive starts without problems
Windows
Progress 9.x
OpenEdge 10.x
CAUSE:
AppServer can not connect to the database with its mapped drive reference.
FIX:
1) Modify the <database name>.st file to have only UNC references to the database for all files (database, BI, AI, TL etc...)
2) Use prostrct repair to imprint the database with your modified copy of the .st file which contains only UNC references to the database.
3) Startup the database using a UNC path reference to the database.
4) At this point if you define the AppServer to use the UNC path reference to the database the AppServer will start and will connect to the database and continue running.