Consultor Eletrônico



Kbase P96718: Probkup receiving 5022 errors when going through crash recovery due to forced shutdown
Autor   Progress Software Corporation - Progress
Acesso   Público
Publicação   19/08/2010
Status: Verified

SYMPTOM(s):

Probkup receiving 5022 errors when going through crash recovery.

SYSTEM ERROR: Ixundo failed in ixdel because it was unable to find the key to delete in index number <index number>. This Index may have an incorrect key. (5022)

Emergency shutdown was initiated automatically because some clients would not terminate their sessions.

Begin transaction backout. (2252)

Transaction backout completed. (2253)

Some client sessions have a 2252 message but no corresponding 2253 message.

Client processes that do not have a 2253 error associated with them were destroyed by the broker.

Destroyed user <userid> pid <PID>. (2251)

Probkup command initiated crash recovery due to previous forced shutdown.

Receive the 5022 error when going through Logical Undo Phase of crash recovery.

Logical Undo Phase of crash recovery completes without any further errors.

FACT(s) (Environment):

Database was shutdown prior to the backup via a normal shutdown command.
Database manager is able to go through Physical Redo and Undo portions of crash recovery.
All Supported Operating Systems
Progress/OpenEdge Product Family

CAUSE:

Logical index corruption associated with the forced shutdown.

FIX:

If the database was able to complete startup, then no further action is required. No further action is required because in order to have the database startup, the database manager must be able to complete all phases of crash recovery. To validate the integrity of your indexes online use the idxfix option to proutil. Command syntax: proutil <dbname> -C idxfix