Consultor Eletrônico



Kbase P96618: ProxyGen does not start if Progress is installed on a shared network drive
Autor   Progress Software Corporation - Progress
Acesso   Público
Publicação   01/08/2005
Status: Unverified

FACT(s) (Environment):

Windows NT 32 Intel/Windows 2000
OpenEdge 10.x

SYMPTOM(s):

ProxyGen does not start

Proxygen causes access violation

Progress is installed as shared network installation

Progress executables are located on a local intranet disk

Microsoft .NET Framework is installed

CAUSE:

Security issue: Microsoft's default is to not fully trust storage devices on the local intranet.
That causes that ProxyGen has no permission to start.

FIX:

Give fully trust permission to proxygen.exe.

Follow these steps:
From the Control Panel -> Administrative Tools -> Microsoft .NET Framework 1.1 Configuration -> Runtime Security Policy choose as Tasks -> increase Assembly Trust.
There choose -> Make changes to that computer -> Next
Than click on the Browse button to choose proxygen.exe from your remote intranet location -> open it -> Next -> increase than the minimal level of trust for this assembly to Full Trust and click on the Finish button to finally set the fully trust to proxygen.exe .