Kbase P96309: SQL-92 DBA account receives Access denied[Authorization failed] after users were added in the 4GL S
Autor |
  Progress Software Corporation - Progress |
Acesso |
  Público |
Publicação |
  02/01/2009 |
|
Status: Verified
SYMPTOM(s):
The SQL-92 DBA account (creator of the database) can no longer access the database
SQL Error State:S1000, Native Error Code: FFFFBOFC, ODBC Error: [DataDirect:Technologies][ODBC PROGRESS driver][PROGRESS]Access denied(Authorization failed)
All 4GL users require a password
4GL users that were added have full rights on the 4GL side.
FACT(s) (Environment):
Progress 9.x
OpenEdge 10.x
OpenEdge Category: Database
CHANGE:
4GL users added to the user list under the Data Administration Utility security section
CAUSE:
When users are added to the users list via the Data Administration Utility, all users are then required to enter a password to gain access to the database. That includes access from the SQL-92 side.
FIX:
To regain access to the database from the SQL-92 side by the SQL-92 DBA or by the sysprogress account, delete all recently added users, or
Add one of the following accounts on the 4GL side: the user that created the database (SQL-92 DBA) or the default SQL-92 user account (sysprogress)
1. Login to the database from the 4GL side as anyone of the 4GL users added to the User List
2. Select Data Administration from the Tools menu
3. Select Security
4. Select Edit User List
5. Add the sysprogress user account or the account that created the database
6. Make note of the password you assign for each account
7. Login from the SQL-92 side with either the sysprogress account or the SQL-92 DBA, using the appropriate password