Consultor Eletrônico



Kbase P92065: WebSpeed agent getting error 6404 in server.log after applying 9.1D09
Autor   Progress Software Corporation - Progress
Acesso   Público
Publicação   16/02/2005
Status: Verified

FACT(s) (Environment):

Progress 9.1D
WebSpeed 3.1D
OpenEdge 10.0A
OpenEdge 10.0B

SYMPTOM(s):

Getting error 6404 in WebSpeed server log during the peak time

WTA: WebWrite() failed during npp_send with error: size: sentbytes retrycount (6404)

Using shared memory connection to the database

Errors are not present in a service pack prior to 9.1D09 (i.e. no errors 9.1D07, 9.1D08 etc..)

CHANGE:

Upgraded to Progress 9.1D09 service pack

CAUSE:

Bug# 20040818-021

CAUSE:

This is a regression bug and the side effect of the bug (20030131-011) fixed in service pack 9.1D09. The webwrite error occurs when an agent is timing out while waiting for the record lock in a shared memory connection to the database.

FIX:

Here are some alternative options to work around the problem. Please note, for Option 1 and 2, you will need to contact your Sales rep.

Option 1. Upgrade Progress 9.1E/3.1E
Option 2. Upgrade to OpenEdge 10.0B01 (OE commercial release with service pack 01)
Option 3. Use client/server connection to the database instead of shared memory connection