Consultor Eletrônico



Kbase P91759: Appserver crashes after displaying error 140 in Server log
Autor   Progress Software Corporation - Progress
Acesso   Público
Publicação   29/10/2008
Status: Verified

SYMPTOM(s):

Appserver server process crashes

** Pipe to subprocess has been broken. (140)

Connection failure for host <host2> port <port> transport <transport_name>. (9407)

Connection failure for host <host2> port <port> transport TCP. (9407)

Error 140 and error 9407 in Appserver server log file

State-reset AppServer

The App servers are NOT connected to the database from command line

Clients that were connected to AppServer process crashed.

Error 140 is related to the crashed clients

AppServer process crashes when it tries to service the next request.

The next client process reports system error 9407.

FACT(s) (Environment):

Progress 9.1D
OpenEdge 10.x
All Supported Operating Systems
OpenEdge Server Technology Category: AppServer

CAUSE:

Bug# OE00105892

CAUSE:

When one of the clients connecting to app server either crashes or for some reason there are network issues, the appserver will display error 140. At this point when the next client request comes in and when databases are connected non command line, the code was not resetting itself properly, causing the App server to crash.

FIX:

Upgrade to 9.1E, 10.0B01 or 10.1A