Kbase P82969: Error connecting 9.1D08 or 9.1D09 client to database using ServiceName beginning with numbers
Autor |
  Progress Software Corporation - Progress |
Acesso |
  Público |
Publicação |
  29/10/2008 |
|
Status: Verified
SYMPTOM(s):
prowin32 client fails using servicename that contains numbers with (1432) error:
** Could not connect to server for database <DATABASE>, errno <ERRNO>. (1432)
Prowin32 client fails with 1432 error when connecting using -S servicename
Mpro client fails with 704 error when connecting using -S servicename
** There is no server active for database <database> on -H <hostname> -S <servicename>. (704)
-S servicename begins with numbers
Can connect to database using the SQLExplorer
Upgraded client to 9.1D08
Upgraded client to 9.1D09
FACT(s) (Environment):
Progress 9.1D
UNIX
Windows
CAUSE:
Bug# 20040603-052
CAUSE:
The connection code is not considering service names with leading numbers to be an actual service name but, rather, a port number.
Client is attempting to connect to the database using the digits in the servicename and not the port name it is mapped to in the SERVICES file.
To demonstrate:
1) Enter "1265prog" as a service port name in the SERVICES file and map it to port 5565.
2) Start the Progress database with -S 1265prog
3) Launch a Progress client session connecting with -S 1265prog. An error will appear.
4) Launch another Progress client session and specify -S 5565. The connection will succeed.
CAUSE:
Bug# OE00105278
FIX:
Upgrade 9.1E or 10.0B. If unable to upgrade at the present time, use the following workarounds to the problem: connect the client using the service port number or rename the service name without leading numbers.