Kbase P100898: Starting the SonicMQ adapter fails with error message in the sonicMQ1.server.log
Autor |
  Progress Software Corporation - Progress |
Acesso |
  Público |
Publicação |
  08/10/2009 |
|
Status: Verified
SYMPTOM(s):
SonicMQ adapter does not start
Error message in the sonicMQ1.server.log
com.progress.javafrom4gl.services.jms.jms or SonicMQ client not found.
FACT(s) (Environment):
OpenEdge 10.0B
Windows 32 Intel
CAUSE:
SonicMQ adapter is not enabled. SonicMQ client archives missing.
FIX:
To enable the Adapter for SonicMQ:
1. On the OpenEdge host, create a subdirectory named /sonicMQ/lib in the directory named
OpenEdge-Install-Directory/java.
2. Copy the following files from SonicMQ-Install-Directory/lib (in the SonicMQ home
area) to OpenEdge-Install-Directory/java/sonicMQ/lib (in the OpenEdge home
area):
? activation.jar
? sonic_ASPI.jar
? sonic_Client.jar
? sonic_Crypto.jar
? sonic_Selector.jar
? sonic_XA.jar
? sonic_XMessage.jar
3. Make sure that pluginclasspath and classpath properties are correctly set in AdminServerPlugins.properties under [PluginPolicy.Progress.SonicMQ] section.