Consultor Eletrônico



Kbase P96014: Progress Explorer fails to connect AdminServer reporting Java exception when using McAfee Firewall
Autor   Progress Software Corporation - Progress
Acesso   Público
Publicação   3/19/2009
Status: Verified

SYMPTOM(s):

Progress Explorer fails to connect AdminServer reporting Java exception when using McAfee Firewall

Java exception reported on attempted connection from the Progress Explorer

java.rmi.server.ExportException

Message (excp): Unable to create remote reference; nested exception is:
java.rmi.server.ExportException: Listen failed on port: 0; nested exception is:
java.net.SocketException: Socket listen failed

Stack Trace: java.rmi.server.ExportException: Unable to create remote reference

Command utilities (asbman, nsman, etc.) invoked from PROENV work normally

PROADSV reports that AdminServer is alive

FACT(s) (Environment):

Progress 9.x
OpenEdge 10.x
Windows

CAUSE:

McAfee Firewall software installation prevents Java opening the ports required for the AdminServer connection

FIX:

Create a rule in McAfee Firewall that allows connections to the AdminServer.
- OR -
Uninstall the McAfee software package.
Ensure that all files and Registry entries associated with the McAfee software have been removed.
Reinstall McAfee.

Note that just disabling McAfee might not be enough, it has sometimes been seen that disabling McAfee doesn't stop the McAfee processes from running. You can confirm this by using the Process Explorer tool from Sysinternals .