Kbase P95570: Progress Explorer does not start and no error messages are displayed
Autor |
  Progress Software Corporation - Progress |
Acesso |
  Público |
Publicação |
  10/15/2008 |
|
Status: Verified
FACT(s) (Environment):
Windows NT 32 Intel/Windows 2000
Progress 9.1C
Progress 9.1D
SYMPTOM(s):
Progress Explorer does not start
No error messages displayed
MS java is properly installed
Registering proexptlr.dll does not help
CHANGE:
Uninstalled Progress 9.1C
CAUSE:
Registry entries remained after 9.1C uninstall causing improper installation of 9.1D
FIX:
1. Backup %DLC%\properties files
2. Uninstall the Progress 9.1D
3. Remove DLC, DLCBIN, PROMSGS environment variables and %DLC%\bin from the PATH environment variable
4. After the uninstall, check and remove the following registry keys (for Progress Explorer 9.1C) :
HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\MMC\SnapIns\{ED06106E-40A4-11d4-81B3-00C04 F6B9729}
HKEY_LOCAL_MACHINE\SOFTWARE\Classes\CLSID\{ED06106E-40A4-11d4-81B3-00C04F6B9729}
HKEY_CLASSES_ROOT\CLSID\{ED06106E-40A4-11d4-81B3-00C04F6B9729}
5. Repeat the last step for any left-overs from Progress Explorer 9.1D :
HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\MMC\SnapIns\{48D545A7-E454-11D5-9E56-00C04 F68C4F1}
HKEY_LOCAL_MACHINE\SOFTWARE\Classes\CLSID\{48D545A7-E454-11D5-9E56-00C04F68C4F1}
[HKEY_CLASSES_ROOT\CLSID\{48D545A7-E454-11D5-9E56-00C04F68C4F1}
6. Install the Progress 9.1D
7. Apply the Progress 9.1D service pack
8. Restore property files from the step 1 backup into the Progress installation directory \properties