Kbase P95294: Error 9407 connecting to the Appserver on Linux from a remote client
Autor |
  Progress Software Corporation - Progress |
Acesso |
  Público |
Publicação |
  28/11/2008 |
|
Status: Verified
SYMPTOM(s):
Error 9407 connecting to the Appserver
Connection failure for host <host> port <port> transport TCP. (9407)
Connection failure for host 127.0.0.1 port <port> transport TCP. (9407)
Remote client connection to the Appserver fails
Local client connection to the Appserver works
FACT(s) (Environment):
UNIX
Progress/OpenEdge Product Family
OpenEdge Server Technology Category: AppServer
CAUSE:
The hosts file has an incorrect entry. Specifically, the host name and the IP address must not appear on the same line as the loopback address (127.0.0.1). The loopback address, 127.0.0.1, is reserved for localhost.
FIX:
1. Go to the /etc/hosts file and make sure that there is one and only one line with the host name (testmachine in this case)
with the IP address of the machine. The host name and the IP address must not appear in any other line.
For example the following snippet from /etc/hosts is correct:
# correct snippet
127.0.0.1 loopback
196.73.183.13 testmachine
The following snippets are not correct (the reason is given in the comment):
# incorrect snippet 1
127.0.0.1 loopback testmachine # testmachine maps to 127.0.0.1 !
# incorrect snippet 2
127.0.0.1 loopback
196.73.184.25 testmachine # two lines with host testmachine !
196.73.183.13 testmachine
# incorrect snippet 3
127.0.0.1 loopback
196.73.183.13 testalias # two lines with IP address 196.73.183.13 !
196.73.183.13 testmachine
2. After changing the /etc/hosts file, stop and restart the AdminServer.