Kbase P95265: Connection from .Net client fails with 7251 error, "Connect failure: No Available Servers"
Autor |
  Progress Software Corporation - Progress |
Acesso |
  Público |
Publicação |
  12/23/2008 |
|
Status: Verified
SYMPTOM(s):
Attempt to connect from a .Net client fails
Progress.Open4GL.DynamicAPI.SessionPool+NoAvailableSessionsException: SessionPool : NoAvailableSessions[Connect failure: No Available Servers (7251) ]
FACT(s) (Environment):
OpenEdge 10.x
Windows
CAUSE:
When a client connects to the AppServer the connection is a two step process. First, a socket connection is established to the AppServer Broker. At that point the client is 'physically' connected to the AppServer. However, the AppServer Broker must in turn send a request to an AppServer Server process to run the 'Connect' procedure even if there is no connect procedure defined in the AppServers configuration in the ubroker.properties file. Once this run of the 'Connect' procedure is complete the client is then logically connected. When all of the AppServer Server processes are busy executing requests on behalf of other clients and the maximum number of active Server processes (_proapsv) have been started error 7251 will be returned to the client and within the message text of the error will be the string ''Connect failure: No Available Servers".
FIX:
Modify the client code to recognize this error and attempt to reconnect to the AppServer