Consultor Eletrônico



Kbase P94627: Progress Explorer unable to connect to AdminServer when Norton Internet Security is blocking ports.
Autor   Progress Software Corporation - Progress
Acesso   Público
Publicação   2/24/2009
Status: Verified

SYMPTOM(s):

Progress Explorer unable to connect to AdminServer

java.rmi.UnmarshallException

Message (throw): Exception of expressing interest to EStartServiceEvent

Message (excp): RemoteException occurred in server thread


java.rmi.UnmarshalException: error unmarshalling arguments; nested exception is:
java.io.InvalidClassException: com.progress.ubroker.tools.events.EStartServiceEvent; Local class not compatible: stream classdesc serialVersionUID= 3577653302636537207 local class serialVersionUID=-7968642171293445923


FACT(s) (Environment):

Progress 9.1x
Running Norton Internet Security
Progress Explorer and AdminServer both using same version and same Service Pack level
Norton Internet Security installed
Windows

CAUSE:

Norton Internet Security was blocking ports used for communication between the Progress Explorer and the AdminServer.

FIX:

Make sure any firewall package or port blocking package is configured to allow the AdminServer port connection from the Progress Explorer machine.