Kbase P94549: Performance degradation after losing connection to the database and appservers
Autor |
  Progress Software Corporation - Progress |
Acesso |
  Público |
Publicação |
  9/14/2004 |
|
Status: Unverified
FACT(s) (Environment):
Solaris SPARC 9 64-bit
FACT(s) (Environment):
Progress 9.1D
SYMPTOM(s):
Performance degradation after losing connection to the database and appservers
Using a WAN via dish/satellite
The comunicattion link between the clients to the database and to the Appservers has been broken
Connecting time to the database is the operation most impacted
It takes about 1 minute to reconnect after losing the connection, as opposed to 2 seconds comparing to the first connection
Databases and AppServer need to be restarted several times in order to restore the original performance
Have about 250 users
Have about 15 Databases connected
Using between 10 to 25 servers per Database broker
Database and AppServer are on separate Solaris SPARC 9 machines
Client is on windows
Using local Progress installation on the clients
Clients uses Application code from local drive
While problem is happening ping the time from the server to the clients are much higher than usual
CAUSE:
This is a WAN tcp/ip configuration issue
FIX:
Monitor tcp/ip packages using a network tool to identify what is happening to the tcp/ip packeges