Consultor Eletrônico



Kbase P94519: .Net application gets 'NoAvailableSessionsException' exception
Autor   Progress Software Corporation - Progress
Acesso   Público
Publicação   12/23/2008
Status: Verified

SYMPTOM(s):

An unhandled exception of type 'NoAvailableSessionsException' occurred in SomeOpenClientProxy.dll

Additional information: SessionPool : NoAvailableSessions[Connect failure: Max client connections has been reached (7251) ]

ASP.Net application terminated after not being able to establish a connection to the AppServer

AppServer is running in stateless operating mode

Application code is structured properly

More instances of client application are running than the defined 'Maximum Servers' for the AppServer

FACT(s) (Environment):

OpenEdge 10.x
Windows

CAUSE:

The 'Request timeout' property of the AppServer Broker has been exceeded. The AppServer Broker defines how long (in seconds) the broker will queue up a request when there are no servers available to execute it. By default, this value is 15 seconds.

FIX:

Modify the 'Request timeout' property of the AppServer broker as follows:

1) Open Progress Explorer
2) Connect to the appropriate Admin Service
3) Right click on the appropriate AppServer
4) Select 'Properties' from the popup menu

At this point the properties window will be displayed for the AppServer

5) Click the plus sign to the left of the 'Broker' entry
6) Click the 'Advanced Features' entry
7) Change the 'Request timeout' field to whatever value is deemed appropriate
for the application
8) Click the 'OK' button
9) Stop and restart the AppServer