Kbase P89599: Cannot login to a Fathom console after cluster node switch
Autor |
  Progress Software Corporation - Progress |
Acesso |
  Público |
Publicação |
  9/30/2004 |
|
Status: Verified
FACT(s) (Environment):
Progress 9.1D
OpenEdge 10.0B
Fathom for Management 2.X
Fathom for Management 3.0A
SYMPTOM(s):
Cannot login to a Fathom console after cluster node switch
FAIL!! User admin failed authentication: General Exception:
java.lang.SecurityException: unable to instantiate LoginConfiguration
FAIL!! Failure authenticating JaasUser(admin) for realm Fathom
Realm: invalid user password
The user name and password are correct
Cluster nodes are using shared device with 1 installation of Fathom and Progress
Remote monitoring has been enabled
FAIL!! User admin failed authentication: General Exception: java.lang.SecurityException: unable to instantiate LoginConfiguration
Unable to access Fathom Management Console after cluster node switch
CAUSE:
The shared installation of Progress does use locally installed java version (locally stored in /opt which was not shared device between nodes). Since the remote monitoring has been enabled, the problem lies in jaas.jar responsible for the authentication. jaas.jar gets copied into $JREHOME/lib/ext/ folder during fmconfig -enable (= installation of remote monitoring). Since the java is installed locally and it is not shared, the jaas.jar file is missing on the 2nd node, which makes authentication failing.
FIX:
Copy $JREHOME/lib/ext/jaas.jar file from 1st node to 2nd node as well, or make the java installation shared between nodes.