Consultor Eletrônico



Kbase P15906: WebSpeed broker does not start with error 8044 in the broker log
Autor   Progress Software Corporation - Progress
Acesso   Público
Publicação   08/09/2008
Status: Verified

SYMPTOM(s):

WebSpeed broker does not start with error 8044 in the broker log

Could not listen on port: 3055 (8044)
java.net.BindException: Address in use: JVM_Bind
at java.net.PlainSocketImpl.socketBind(Native Method)
at java.net.PlainSocketImpl.bind(PlainSocketImpl.java:397)
at java.net.ServerSocket.<init>(ServerSocket.java:170)
at java.net.ServerSocket.<init>(ServerSocket.java:121)
at com.progress.ubroker.broker.ubListenerPort.<init>(ubListenerPort.java:106)
at com.progress.ubroker.broker.ubListenerThread.initializeListenerThread(ubListenerThread.java:317)
at com.progress.ubroker.broker.ubListenerThread.run(ubListenerThread.java:230)

FACT(s) (Environment):

WebSpeed 3.x
OpenEdge 10.x
All Supported Operating Systems

CAUSE:

The cause of the problem is unknown at this time of writing. However, the possible cause for this problem is apparent when the broker port hangs for some unknown reasons.

FIX:

There are two workarounds to fix this issue:

1. Reboot the WebSpeed Transaction Server machine

Or

2. Change the broker port to an available unused port, and restart the broker