Consultor Eletrônico



Kbase P91951: Unable to connect from/to Progress services after installing Windows XP SP2
Autor   Progress Software Corporation - Progress
Acesso   Público
Publicação   19/03/2009
Status: Verified

SYMPTOM(s):

Unable to use client server connection after installation of Windows XP SP 2 SP2

Problems connecting to AppServer after installation of Service Pack 2 for Windows XP

Cannot establish connection from Progress Explorer to AdminServer after installation of Windows XP SP 2 SP2

File sharing to Windows XP works without problem

Able to map and access Windows XP shared drive

Unable to connect to Admin Server. Ensure Admin Server is running. (8336)

** Could not connect to server for database <DATABASE>, errno 0. (1432)

Name Server at Host <Host> Port <Port> is not responsive. (8239)

Application Service <Application Service> not found at NameServer at Host <Host> Port <Port>. (8245)

Connection failure for host <host_name> port 1243628 transport TCP. (9407)

Application server connect failure. (5468)

The ASK major version in the CONNECT request is invalid (com.progress.ubroker.util.ubMsg$InvalidMsgVersionException: MsgFormat). AppServer Keepalive protocol is disabled for this connection. (13766)

FACT(s) (Environment):

Windows XP
Progress 9.x
OpenEdge 10.x

CHANGE:

Installed SP2 - Service Pack for Windows XP

CAUSE:

Internal Windows firewall is enabled by default after SP2 installation blocking all connections, except File and Printing shares.

FIX:

The quickest and easiest way to restore the possibility to connect (4GL, AppServer, Progress Explorer ...) is to disable the internal windows firewall.

Following examples (for Client/Server, AppServer and Progress Explorer) can be used in order to keep the firewall running and allow Progress processes to connect.

[Client Server]
The port for the database broker (-S) and range of ports for remote servers (-minport/-maxport) have to be enabled/allowed on the firewall. This can be achieved by adding ports using:
Firewall -> Exceptions -> Add Port.
This might be considered a lengthly exercise especially when lots of databases are being connected and it seems to be impossible to select a port range on firewall. That being the case, instead of adding the individual ports, an executable can be set as "trusted" via:
Firewall -> Exceptions -> Add Program. DLC/bin/_mprosrv.exe for a database if database runs on XP (= you are connecting from PC to database residing on XP running firewall) or DLC/bin/prowin32.exe (or _progres.exe) when connecting from a WINXP client machine running firewall.

[NameServer, AppServer ...]
Firewall -> Exceptions -> Add Port : the NS port would be UPD, and then depending on the AppServer mode:
- stateless: TCP port for broker must be opened,
- statereset/stateaware: TCP port for broker and agents must be opened.
Again it may well be easier to use:
Firewall -> Exceptions -> Add Program and add DLC/jre/bin/java.exe in this case.

[Progress Explorer]
Firewall -> Exceptions -> Add Program and add DLC/jre/bin/java.exe

In all cases, you can restrict the network (LAN, all, specify subnet or particular ip address) the request is coming from via the "change scope" option.