Kbase 16957: Unable to Attach Shared Memory (1720) when attempting to connect with a self-service client to a dat
Autor |
  Progress Software Corporation - Progress |
Acesso |
  Público |
Publicação |
  10/10/2007 |
|
Status: Verified
FACT(s) (Environment):
Windows NT 32 Intel/Windows 2000
Progress 8.2x
Progress 8.3x
Progress 9.x
Windows
SYMPTOM(s):
There is no server for database <dbname>. (1423)
Unable to attach shared memory <shmname>, error <n>. (1720)
Unable to attach shared memory <shmname>, error 5. (1720)
Error connecting to database with a self-service client.
Error connecting to a database with PROMON
Database is started via Procontrol/Proservice
Error 5 on Win32 platforms means: ERROR_ACCESS_DENIED Access is denied.
CAUSE:
Users do not have permission to access database shared memory.
FIX:
Shut down database and stop Proservice
Follow these steps to set the access environment variable:
1) Go into ProControl.
2) Click on the Detail button.
3) Go to the Environment tab.
4) Where it says "Variable", type ACCESS.
5) Where it says "Value", type ALL.
Restart Proservice and database.