Consultor Eletrônico



Kbase P91603: Unable to connect to MS SQL Server via Unified Broker using NT Authentication
Autor   Progress Software Corporation - Progress
Acesso   Público
Publicação   4/27/2010
Status: Verified

SYMPTOM(s):

Errors 7255 and 6142 trying to connect to SQL Server database using broker started viua Progress Explorer

DataServer connection failure. (7255)

Failed to connect to the <db-type> database. (6142)

When Starting broker via Progress Explorer client could not connect with error:

28000: [Microsoft][ODBC SQL Server Driver][SQL Server]Login failed for user 'xxx\xxx'.

Error "Posted EAbnormalShutdownServerEvent for PID:xxx" in broker log.

Error 1891 written to dataserv.lg

BROKER: The server could not open the foreign database. (1891)

FACT(s) (Environment):

When Starting broker manually using _probrkr, the connection works fine
ODBC Data Source configured to use MS SQL Server's NT Authentication
MS SQL Server on different machine than where the broker is running
Progress 9.1x
OpenEdge 10.x
Windows
MS SQL DataServer

CAUSE:

The NT Authentication requires that the user trying to connect to the MS SQL Server database must be a domain user and can be authenticated. On the machine that the broker was started from, it was started using the "local user account" which is not a domain user and therefore could not be authenticated on the machine running SQL Server.

FIX:

In the Progress Explorer's Broker properties, enter owner information for a domain user which can be authenticated via NT Authentication on the SQL Server Machine.