Kbase P91225: Unable to start AdminServer - The persistent cache is locked when starting AdminServer on a Fathom r
Autor |
  Progress Software Corporation - Progress |
Acesso |
  Público |
Publicação |
  1/25/2007 |
|
Status: Verified
FACT(s) (Environment):
Progress 9.1D
OpenEdge 10.0B
Fathom Management 2.1A
Fathom Management 3.0A
SYMPTOM(s):
Unable to start AdminServer on a machine remotely monitored by Fathom Management
Remote AdminServer has not been properly shutdown
The server running remote AdminServer has been powered off
Using Fathom Management remote monitoring
Following messages appear in the Fathom1.FathomAdminserver1.log file:
The persistent cache is locked when starting AdminServer on a Fathom remote machine
The persistent cache is locked. There is either another MF container using this cache or the previous session did not shutdown properly.
If the previous session did not shutdown properly then "./Fathom1.remotemachinename.cache" is corrupt and must be deleted before restarting the container.
(severe) Persistent cache failure...
(info) Unloaded ID=AGENT
(info) Exiting...
CAUSE:
This condition is caused by the AdminServer terminating abnormally (Veritas NetBackup, server reboot while AdminServer is running or server crashes for example). When the AdminServer is restarted, if fails as the persistent cache is locked to the previous instance of the AdminServer running.
The persistent cache is used until a connection to the directory services on the Fathom machine is made. If this cache is deleted and Fathom is not running the remote Adminserver will hang until Fathom starts. This prevents the utility from deleting it if present every time the AdminServer starts.
FIX:
In the first instances, ensure that:
1.) The Progress | Fathom environment (files and executables) are in the exclusion lists of 3rd Party tools while running
2.) Always gracefully shut down running processes before a system reboot
Where an instance is unavoidable (server crash for example) resolve the AdminServer startup failure by:
- In the working directory of Progress installation on the remote machine:
Delete directory Fathom1.remotemachinename.cache.
Then restart the (remote) AdminServer.