Kbase P91021: Unable to install Progress because an installation is detected after uninstall was done.
Autor |
  Progress Software Corporation - Progress |
Acesso |
  Público |
Publicação |
  12/5/2008 |
|
Status: Verified
SYMPTOM(s):
Unable to install Progress.
Previous Progress installation is detected.
Previous installation of Progress failed.
Deleted \HKEY_CURRENT_USER\Software\PSC from the Registry.
Deleted \HKEY_LOCAL_MACHINE\Software\PSC from the Registry.
FACT(s) (Environment):
Windows
Progress 9.x
CAUSE:
There are registry entries for Progress that should not be in the registry that are detected and preventing a fresh install.
FIX:
The registry needs to be cleaned better.
1. In Windows select run/regedt32
2. Search for the following keys in ControlSet001, ControlSet003, and CurrentControlSet and remove those that are found.
NOTE: Replace the "x" in AdminService9.x and ProService9.x with the version of Progress being removed.
HKEY_LOCAL_MACHINE\SYSTEM\ControlSet001\Services\AdminService9.x
HKEY_LOCAL_MACHINE\SYSTEM\ControlSet001\Services\ProService9.x
HKEY_LOCAL_MACHINE\SYSTEM\ControlSet003\Services\AdminService9.x
HKEY_LOCAL_MACHINE\SYSTEM\ControlSet003\Services\ProService9.x
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\AdminService9.x
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\ProService9.x
3. Select Windows Run/Settings/Control Panel/Add/Remove Programs, If the version of Progress to be installed is listed at this time, select REMOVE, it not continue with step 4.
4. Install Progress using Windows Add/Remove Programs utility.