Kbase P91010: Database will not start with errors 9215,9213,1486
Autor |
  Progress Software Corporation - Progress |
Acesso |
  Público |
Publicação |
  10/29/2008 |
|
Status: Verified
SYMPTOM(s):
Database will not start
Last open date mismatch. (9215)
Extent <file-name> has a different last opened date <timestamp>, (9213)
Database is damaged, see documentation. (1486)
FACT(s) (Environment):
All Supported Operating Systems
Progress/OpenEdge Product Family
CAUSE:
After image extents were moved instead of copied after filling up.
FIX:
1. Restore the most recent backup, backup the database again, and run after imaging. The database should now start. This will result in loss of data since the most recent backup.
2. Back up your currently corrupted database using operating system tools in case something goes wrong, then proceed to do the following:
a. Copy the ai extents back using cp -p
b. Run the Progress command:
prostrct unlock <db-name>
This command will correct any date mismatches.
However, the database needs to be dumped and loaded after running this command. It may take significant time to do this depending on the database size.