Consultor Eletrônico



Kbase P90241: SonicMQ Adapter Server remains unavailable after the Adapter client exits.
Autor   Progress Software Corporation - Progress
Acesso   Público
Publicação   10/1/2004
Status: Unverified

FACT(s) (Environment):

SonicMQ

SYMPTOM(s):

SonicMQ Adapter broker log, <SonicMQ Adapter name>.broker.log contains the following error:

ERROR: No servers available. (8089)

AppServer Server log, <AppServer name>.server.log contains the following error:

(Procedure: 'startReceiveMessages jms/impl/session.p' Line:1265) Adapter error:

Appserver Broker log, <AppServer name>.broker.log contains the following error:

Message from server : Startup Procedure Failed (8113)

CAUSE:

The SonicMQ Adapter clients' session resources were not cleaned up properly. Because of this, the SonicMQ Adapter Server thinks that the client is still active.

FIX:

Be sure to cleanup session resources before exiting the program. For example:
RUN deleteSession in <Session Handle>.