Kbase P88747: Remote client can not connect to database with error 1154, 748 or 1432, caused by firewall
Autor |
  Progress Software Corporation - Progress |
Acesso |
  Público |
Publicação |
  27/08/2008 |
|
Status: Verified
SYMPTOM(s):
Remote client can not connect to database with error 1432
** Could not connect to server for database <DATABASE>, errno <ERRNO>. (1432)
** Could not connect to server for database sports, errno 10060. (1432)
Error 748 and 1154 encountered when remote clients attempt connection
The server or the system has no more resources. Try a larger -n. (748)
No servers are available. Try again later. (1154)
Attempted to create sports2000 database and start server for sports2000 and was prompted by the Windows Operating System to Block or Unblock the port.
Remote WebSpeed clients can not connect to database
ping serverip successful
telnet {serverip} {port#} not successful
FACT(s) (Environment):
Database server was not started with '-H localhost'
Database license is installed
Shared memory connection on local machine works
The database log file <dbname.lg> shows that multiple remote servers have been spawned but no remote clients connected
All Supported Operating Systems
Progress/OpenEdge Versions
CAUSE:
A Firewall issue. -S port was open but TCP ports for auto servers were not all open. When WebSpeed broker asks for a connection, the database server, though started, can not respond. So all servers were used up by WebSpeed asking for a connection that could not be completed.
FIX:
Open the Firewall ports for database brokers (primary and secondary) as well as all ports for auto servers.
Database startup parameters -minport and -maxport control port range for auto servers
Exclusions may be defined for specific executable names which reduces the possibility for mistakes in port exclusions but opens the ports to all such servers.
If an exclusion is made based on executable name then remember the common executable names for the two primary listeners are: _mprosrv and _sqlsrv2.