Consultor Eletrônico



Kbase P88561: Clients using Windows XP Home do not display the correct username in promon
Autor   Progress Software Corporation - Progress
Acesso   Público
Publicação   11/1/2004
Status: Unverified

SYMPTOM(s):

Username in promon doesn't match clients machine login name

Using Windows XP Home

Client renamed operating system account on Windows XP Home yet sees the old name displayed in promon

Client renamed operating system account on Windows XP Pro yet doesn't see the old name displayed in promon

CAUSE:

Windows XP Home does not correctly update the USERNAME environment variable which Progress uses if no user name is supplied when a database connection is made.

Renaming an account in Windows XP Home does not appropriately change registry entries to reflect the new account name. Windows will accept a logon by the new username, however all registry references will still point at the original account name.

FIX:

1) Please backup all relevant files owned by this user.
2) Delete the account and recreate the account.
This is necessary for Windows to fully update the appropriate registry entries which Windows uses to set the USERNAME variable.