Consultor Eletrônico



Kbase P87763: Progress Explorer fails to show databases and services after installing 9.1D09 on Windows
Autor   Progress Software Corporation - Progress
Acesso   Público
Publicação   28/01/2005
Status: Verified

FACT(s) (Environment):

Progress 9.1D
Windows NT 32 Intel/Windows 2000

SYMPTOM(s):

Unable to start AdminServer on Windows NT 4 after applying Service pack 09

java.lang.UnsatisfiedLinkError: jniGetOSMetricsVersion at com.progress.osmetrics.OSMetricsImpl.jniGetOSMetricsVersion(Native Method) at com.progress.osmetrics.OSMetricsImpl.getOSMetricsVersion(OSMetricsImpl.java:263)

osmetrics.dll: Can't find dependent libraries

Progress Explorer fails to show databases and services after installing 9.1D09 on Win NT 4 SP6.

Exception in Ads0 file: java.lang.ClassNotFoundException


Message (throw): An Exception occured while loading the osmetrics.dll shared library. (10363)


Message (excp): com.progress.isq.ipqos.Initialization


Stack Trace: java.lang.ClassNotFoundException: com.progress.isq.ipqos.Initialization


The file pdh.dll is in \winnt\system32 directory

Fathom is not installed on the system.

CHANGE:

Installed 9.1D09 - The 9.1D08 worked fine.

CAUSE:

This is a known issue and is being investigated by development. The osmetrics.dll is only related to Fathom.

FIX:

Modify the AdminServerPlugins.datfile found in Progress install directory.
Comment out the following:

Operating System Plugin
#
#SystemPlugIn
#0
#com.progress.system.SystemPlugIn
#progress.jar
#Operating System Plugin

This will avoid the osmetrics.dll to be loaded.
The osmetrics.dll is related to Fathom. The operating system plugins being commented out are related to gathering system information for Fathom's use and will not affect Progress. All of the above assumes Fathom is not being loaded onto the system as part of the install.
Restart the AdminServer.